Graphic texture overload bug

Description: Report bugs, bug fixes and workarounds here.

john71
Topic author
john71
Topic author
Posts: 207
With us: 11 months 10 days

#1by john71 » 16.07.2017, 07:44

I found this very strange bug: I have approximately 100 Earth-like planets with imaginary 8k textures (surface, bump, specular textures).

When I start to open these exoplanets in a row, after cca. 10 planets Celestia crashes.

Initially I thought it must be a 32 bit RAM problem, but the new Alexell released 64 bit version of Celestia 1.7 produces the same bug!

The new 64 bit version can occupy 4GB memory when opening for example a lot of large cmod files, and it won't crash, but for some reason it crashes at 2 GB RAM when opening 10 new 8k exoplanets...!

Can Celestia unload unused planetary textures?

Are planetary textures simultaneous textures for the graphic card (Radeon 7700 1GB)?

FarGetaNik M
Avatar
FarGetaNik M
Posts: 293
With us: 5 years 1 month
Location: Germany

#2by FarGetaNik » 16.07.2017, 18:26

I've tried to load as many texture into the 64bit version of Celestia as I possibly can. I could handle well over 5 GB of RAM usage, before I had to kill it because it started to use my hard drive instead. So in principle I am able to load pretty much the whole solar system now without having to worry it crashes :)

But even so, Celestia becomes very laggy if you hit the limit of your RAM, so it would definately benefit from deleting unused textures from the memory.

I don't know the specifics of Celestia's usage of tetures, but I think it loads it to the graphic somehow. But maybe not always, since I can load more data than my graphics memory as well as non-power-of-2-textues. But it used to crash when trying to load textures larger than my graphics supports (16k). I haven't tried it with this version, because obviously I don't have any single texture that large in my installation left.

John Van Vliet
Avatar
John Van Vliet
Posts: 2602
With us: 14 years 10 months

#3by John Van Vliet » 17.07.2017, 16:20

not really a bug ,more a feature for fast loading
but
it can eat up ram


Return to “Bugs”

Who is online (over the past 5 minutes)

Users browsing this forum: 2 guests